UE4 NDK android-19 non può localizzare 'log2'

wwwcsw 07/19/2017. 1 answers, 47 views
android android android-ndk android-ndk unreal-engine4

Sto riscontrando un problema con un errore di run-time che dice

causato da: java.lang.UnsatisfiedLinkError: Impossibile caricare la libreria: reloc_library [1307]: 1838 non può localizzare 'log2' ...

Le versioni superiori a 19 vanno bene, tuttavia, su dispositivi nella versione inferiore a 19, il mio gioco si blocca per la ragione.

Quello che ho fatto è

Ho dichiarato due definizioni di log2 e log2f su mygame.h

#include "CoreMinimal.h"
#define log2f(x) (logf(x)/logf(2.0f))
#define log2(x) (log(x)/log(2))

DECLARE_LOG_CATEGORY_EXTERN(LogGhost, Log, All); 

Ma ancora non funziona.

1 Answers


Sung 07/29/2017.

Il problema è stato risolto dopo UE4.16.3

Related questions

Hot questions

Language

Popular Tags